Back to overview
Resolved
Server Maintenance
Aug 21, 2026 at 3:25am UTC
–
Aug 21, 2026 at 5:00am UTC
Affected services
bencarpenterit.com
CORS
Rides API
Tutor API
Matrix
Stormageddon
Resolved
Aug 21, 2026 at 5:00am UTC
Maintenance ended
Affected services
Created
Aug 21, 2026 at 3:25am UTC
Updating server operating system
Affected services