Back to overview
Resolved
Server OS Updates
Jul 11, 2026 at 5:00am UTC
–
Jul 11, 2026 at 5:15am UTC
Affected services
bencarpenterit.com
CORS
Rides API
Tutor API
Matrix
Stormageddon
Resolved
Jul 11, 2026 at 5:15am UTC
Maintenance ended
Affected services
Created
Jul 11, 2026 at 5:00am UTC
The Site will be down for the duration of the update to the OS
Affected services